import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\.+)(\\d+(,\\d*)?\\.\\d{2})$";
final String string = "00.0\n"
+ "123\n"
+ "123.\n"
+ "123.123\n"
+ ".13\n"
+ ".123.\n"
+ "123,0.00\n"
+ "12,12.\n"
+ ".12,12.00\n"
+ ".1.\n"
+ "..1.\n"
+ "...12.\n"
+ "...18724.34\n"
+ ".18,724.34";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}