$re = '/^(\.+)(\d+(,\d*)?\.\d{2})$/m';
$str = '00.0
123
123.
123.123
.13
.123.
123,0.00
12,12.
.12,12.00
.1.
..1.
...12.
...18724.34
.18,724.34';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);