package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)lower\(([^)]*)\)`)
var str = `lower(Type)`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}