use strict;
my $str = 'lower(Type)';
my $regex = qr/lower\(([^)]*)\)/mip;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";