const regex = /lower\(([^)]*)\)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('lower\\(([^)]*)\\)', 'gmi')
const str = `lower(Type)`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);