using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^
(?=(a(?-1)?b)(?!b)) a+
(?=(b(?-1)?c))
(b(?-1)?c)
$";
string input = @"aaabbbbcccc";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}