// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)^
(?=(a(?-1)?b)(?!b)) a+
(?=(b(?-1)?c))
(b(?-1)?c)
$").unwrap();
let string = "aaabbbbcccc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}