$re = '/([\d]+\.?[\d]*)|([()\+\-\*\/]+)/';
$str = '5+5-23+5.154*15
5 * 6 + 3 ( 5 / 4)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);