// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([\d]+\.?[\d]*)|([()\+\-\*\/]+)").unwrap();
let string = "5+5-23+5.154*15
5 * 6 + 3 ( 5 / 4)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}