re = /([\d]+\.?[\d]*)|([()\+\-\*\/]+)/
str = '5+5-23+5.154*15
5 * 6 + 3 ( 5 / 4)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end