#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/produto\/(.*)(.)(html)"
Local $sString = "https://atacadogames.com/produto/jogo-sword-art-497329.html" & @CRLF & _
"https://atacadogames.com/produto/carregador-usb-pikachu-446839.html" & @CRLF & _
"https://atacadogames.com/produto/jogo-arms-switch-419772.html" & @CRLF & _
"" & @CRLF & _
"\/produto\/(.*)(.)(html)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")