const regex = /\/produto\/(.*)(.)(html)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/produto\\\/(.*)(.)(html)', 'gm')
const str = `https://atacadogames.com/produto/jogo-sword-art-497329.html
https://atacadogames.com/produto/carregador-usb-pikachu-446839.html
https://atacadogames.com/produto/jogo-arms-switch-419772.html
\\/produto\\/(.*)(.)(html)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}