import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/produto\\/(.*)(.)(html)";
final String string = "https://atacadogames.com/produto/jogo-sword-art-497329.html\n"
+ "https://atacadogames.com/produto/carregador-usb-pikachu-446839.html\n"
+ "https://atacadogames.com/produto/jogo-arms-switch-419772.html\n\n"
+ "\\/produto\\/(.*)(.)(html)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}