package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w{2,}ome\b`)
var str = `The genome of women is home to some of the most comely parts of the human exome: the omega moment that foments the proteome.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}