$re = '/\w{2,}ome\b/m';
$str = 'The genome of women is home to some of the most comely parts of the human exome: the omega moment that foments the proteome.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);