re = /\w{2,}ome\b/m
str = 'The genome of women is home to some of the most comely parts of the human exome: the omega moment that foments the proteome.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end