#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z\d+]\.(\d+)?\.?(\d+)?(\s\(.*\)\s)?\s+"
Local $sString = "" & @CRLF & _
"c.2 Employed population below international poverty line, by sex and age (%) Age: 15+" & @CRLF & _
"b.1 Employed population below international poverty line, by sex and age (%) Age: 15+" & @CRLF & _
"a.1 Employed population below international poverty line, by sex and age (%) Age: 15+" & @CRLF & _
"1. Employed population below international poverty line, by sex and age (%) Age: 15+" & @CRLF & _
"1.2 Employed population below international poverty line, by sex and age (%) Age: 15+ " & @CRLF & _
"1.1.1 Employed population below international poverty line, by sex and age (%) Age: 15+ " & @CRLF & _
"5.6.2 (S.1.C.1) Employed population below international poverty line, by sex and age (%) Age: 15+" & @CRLF & _
"5.6.2 (S.3) Employed population below international poverty line, by sex and age (%) Age: 15+" & @CRLF & _
"5.6.2 (S.4.C.13) Employed population below international poverty line, by sex and age (%) Age: 15+"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")