re = /^[a-z\d+]\.(\d+)?\.?(\d+)?(\s\(.*\)\s)?\s+/m
str = '
c.2 Employed population below international poverty line, by sex and age (%) Age: 15+
b.1 Employed population below international poverty line, by sex and age (%) Age: 15+
a.1 Employed population below international poverty line, by sex and age (%) Age: 15+
1. Employed population below international poverty line, by sex and age (%) Age: 15+
1.2 Employed population below international poverty line, by sex and age (%) Age: 15+
1.1.1 Employed population below international poverty line, by sex and age (%) Age: 15+
5.6.2 (S.1.C.1) Employed population below international poverty line, by sex and age (%) Age: 15+
5.6.2 (S.3) Employed population below international poverty line, by sex and age (%) Age: 15+
5.6.2 (S.4.C.13) Employed population below international poverty line, by sex and age (%) Age: 15+'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end