# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-z\d+]\.(\d+)?\.?(\d+)?(\s\(.*\)\s)?\s+"
test_str = ("\n"
"c.2 Employed population below international poverty line, by sex and age (%) Age: 15+\n"
"b.1 Employed population below international poverty line, by sex and age (%) Age: 15+\n"
"a.1 Employed population below international poverty line, by sex and age (%) Age: 15+\n"
"1. Employed population below international poverty line, by sex and age (%) Age: 15+\n"
"1.2 Employed population below international poverty line, by sex and age (%) Age: 15+ \n"
"1.1.1 Employed population below international poverty line, by sex and age (%) Age: 15+ \n"
"5.6.2 (S.1.C.1) Employed population below international poverty line, by sex and age (%) Age: 15+\n"
"5.6.2 (S.3) Employed population below international poverty line, by sex and age (%) Age: 15+\n"
"5.6.2 (S.4.C.13) Employed population below international poverty line, by sex and age (%) Age: 15+")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.