using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|[^{])(\[\w+\])([^}]|$)";
string input = @"Match value will be like [ua] and [ua_enc] and unmatched should be {[ua]} and {[ua_enc]}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}