re = /(^|[^{])(\[\w+\])([^}]|$)/
str = 'Match value will be like [ua] and [ua_enc] and unmatched should be {[ua]} and {[ua_enc]}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end