package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|[^{])(\[\w+\])([^}]|$)`)
var str = `Match value will be like [ua] and [ua_enc] and unmatched should be {[ua]} and {[ua_enc]}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}