package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^.\s]+\.(?:\R\h+.+)+`)
var str = `TestSuite1.
TestCase1
TestCase2
TestSuite2.
TestCase1
TestCase2
TestCase3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}