re = /[^.\s]+\.(?:\R\h+.+)+/
str = 'TestSuite1.
TestCase1
TestCase2
TestSuite2.
TestCase1
TestCase2
TestCase3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end