import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^.\\s]+\\.(?:\\R\\h+.+)+";
final String string = "TestSuite1.\n"
+ " TestCase1\n"
+ " TestCase2\n"
+ "TestSuite2.\n"
+ " TestCase1\n"
+ " TestCase2\n"
+ " TestCase3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}