const regex = /(?<userid>[^\"]+@[^\"]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<userid>[^\\"]+@[^\\"]+)', 'gm')
const str = `01022703
021216
07602381
"1206931120@GSA.GOV"
177
177670
1969412
232789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}