re = /(?<userid>[^\"]+@[^\"]+)/m
str = '01022703
021216
07602381
"1206931120@GSA.GOV"
177
177670
1969412
232789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end