$re = '/([A-z_$][\w$]*)\s+as\s+([A-z_$][\w$]*)/';
$str = 'const { export1 as alias1 } = require("module-name");
const { export2 as alias2, export3 as alias3 } = require("module-name");';
$subst = "$1: $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;