using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z0-9_]+:)([a-z0-9_]+)(?>\s?(\(.+\)))?$";
string input = @"node
drupal:node
drupal:system (>=8.6.0)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}