re = /^([a-z0-9_]+:)([a-z0-9_]+)(?>\s?(\(.+\)))?$/m
str = 'node
drupal:node
drupal:system (>=8.6.0)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end