$re = '/^([a-z0-9_]+:)([a-z0-9_]+)(?>\s?(\(.+\)))?$/m';
$str = 'node
drupal:node
drupal:system (>=8.6.0)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);