import Foundation
let pattern = #"^(?'asset'02)_(?'market1'\w{3,})\/(?'market2'\w{3,})_(?'type'SE)(?'offset'L)_(?'derivative'PHY|FUT) (?'period'SWS)-(?'year'\d{4})-\b(?'month'0[4]|1[0])\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
02_AUT/TTF_H_SEL_PHY SWS-2015-10
02_AUT/TTF_H_SEL_PHY SWS-2016-04
02_GASPOOL_L/GASPOOL_H_SEL_PHY SWS-2015-10
02_GASPOOL_L/GASPOOL_H_SEL_PHY SWS-2016-04
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)