using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?x) # Free spacing mode, to allow comment and better view
# Matching the first line `i5-2520M`
([^ ]+\s*)(?=CPU\s*@)
# Matching the first line `2.50GHz`
|(?<=CPU)(\s*@\s*\d+.\d+GHz)
# Matching the second line `CPU T2400`
|(CPU\s*[^ ]+\s*)(?=@)
# Matching the second line `1.83GHz`
|\s*(?<=@)(\s*\d+.\d+GHz)";
string input = @"Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
Genuine Intel(R) CPU T2400 @ 1.83GHz";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}