re = /(?x) # Free spacing mode, to allow comment and better view
# Matching the first line `i5-2520M`
([^ ]+\s*)(?=CPU\s*@)
# Matching the first line `2.50GHz`
|(?<=CPU)(\s*@\s*\d+.\d+GHz)
# Matching the second line `CPU T2400`
|(CPU\s*[^ ]+\s*)(?=@)
# Matching the second line `1.83GHz`
|\s*(?<=@)(\s*\d+.\d+GHz)/m
str = 'Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
Genuine Intel(R) CPU T2400 @ 1.83GHz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end