import re
regex = re.compile((r"(?x) # Free spacing mode, to allow comment and better view\n\n"
r"# Matching the first line `i5-2520M`\n"
r"([^ ]+\s*)(?=CPU\s*@)\n\n"
r"# Matching the first line `2.50GHz`\n"
r"|(?<=CPU)(\s*@\s*\d+.\d+GHz)\n\n"
r"# Matching the second line `CPU T2400`\n"
r"|(CPU\s*[^ ]+\s*)(?=@)\n\n"
r"# Matching the second line `1.83GHz`\n"
r"|\s*(?<=@)(\s*\d+.\d+GHz)"), flags=re.MULTILINE)
test_str = ("Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz\n"
"Genuine Intel(R) CPU T2400 @ 1.83GHz")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")