package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<from>(?<hex>[0-9a-fA-F]{1,8}))\s*:\s*(?<to>(\g<hex>))`)
var str = `12345678: 87654321`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}