re = /(?<from>(?<hex>[0-9a-fA-F]{1,8}))\s*:\s*(?<to>(\g<hex>))/
str = '12345678: 87654321'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end