const regex = /(?<from>(?<hex>[0-9a-fA-F]{1,8}))\s*:\s*(?<to>(\g<hex>))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<from>(?<hex>[0-9a-fA-F]{1,8}))\\s*:\\s*(?<to>(\\g<hex>))', 'g')
const str = `12345678: 87654321`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}