using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SEQ \d{3,6}";
string input = @"SEQ 123
SEQ 1234
SEQ 12345
SEQ 123456";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}