$re = '/SEQ \d{3,6}/m';
$str = 'SEQ 123
SEQ 1234
SEQ 12345
SEQ 123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);