#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^protocol://.{36,48}/folder/index\.html(?:\?param=.+)?$"
Local $sString = "protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html" & @CRLF & _
"protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html?param= " & @CRLF & _
"protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html?param=test1234&a=1&b=234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890" & @CRLF & _
"protocol:// /folder/index.html" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")