// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^protocol://.{36,48}/folder/index\.html(?:\?param=.+)?$").unwrap();
let string = "protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html
protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html?param=
protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html?param=test1234&a=1&b=234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890
protocol:// /folder/index.html
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}