import re
regex = re.compile(r"^protocol://.{36,48}/folder/index\.html(?:\?param=.+)?$", flags=re.MULTILINE)
test_str = ("protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html\n"
"protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html?param= \n"
"protocol://1234-1234-1234-1234-1234-1234-1234-1234-1234/folder/index.html?param=test1234&a=1&b=234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890234567890\n"
"protocol:// /folder/index.html\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")