#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[(?P<timestamp>\d+-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d{3})\] (?P<level>[A-Z]+) \[(?P<context>.+?)\] (?P<msg>.+) \((?P<logger>.+)\)"
Local $sString = "[2023-10-24 20:33:14,925] DEBUG [Controller id=2] Topics not in preferred replica for broker 2 Map() (kafka.controller.KafkaController)" & @CRLF & _
"[2023-10-25 00:30:13,095] INFO [RaftManager nodeId=1] Disconnecting from node 2 due to request timeout. (org.apache.kafka.clients.NetworkClient)" & @CRLF & _
"[2023-10-25 00:01:39,422] INFO [RaftManager nodeId=1] Disconnecting from node 2 due to request timeout. (org.apache.kafka.clients.NetworkClient)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")