using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([@a-zA-z0-9._\-!#$%&'*+\/=?^_`{|}~""\(\)<>:,;]+|\""[a-zA-z0-9._\-!#$%&'*+\/=?^_`{|}~""\(\)<>:,; @]+\"")@([a-zA-Z0-9\-]+|\[(.*)\])\.?([a-zA-Z0-9\-]+)?";
string input = @"my-email@outlook.com
my-@-email@outlook.com ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}