re = /([@a-zA-z0-9._\-!#$%&'*+\/=?^_`{|}~"\(\)<>:,;]+|\"[a-zA-z0-9._\-!#$%&'*+\/=?^_`{|}~"\(\)<>:,; @]+\")@([a-zA-Z0-9\-]+|\[(.*)\])\.?([a-zA-Z0-9\-]+)?/
str = 'my-email@outlook.com
my-@-email@outlook.com '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end