package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([@a-zA-z0-9._\-!#$%&'*+\/=?^_`{|}~"\(\)<>:,;]+|\"[a-zA-z0-9._\-!#$%&'*+\/=?^_`{|}~"\(\)<>:,; @]+\")@([a-zA-Z0-9\-]+|\[(.*)\])\.?([a-zA-Z0-9\-]+)?`)
var str = `my-email@outlook.com
my-@-email@outlook.com `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}