using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*(START))(?=.*(END))(?:(?:\1|\2)|(?!^)\G)\h+.*?\b(\w{4,})(?=.*?(?:(?:\1|\2)))";
string input = @"START one two three fifth END
END one two three fifth START
START nothing should be selected here START
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}