re = /(?=.*(START))(?=.*(END))(?:(?:\1|\2)|(?!^)\G)\h+.*?\b(\w{4,})(?=.*?(?:(?:\1|\2)))/
str = 'START one two three fifth END
END one two three fifth START
START nothing should be selected here START
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end