import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*(START))(?=.*(END))(?:(?:\\1|\\2)|(?!^)\\G)\\h+.*?\\b(\\w{4,})(?=.*?(?:(?:\\1|\\2)))";
final String string = "START one two three fifth END\n"
+ "END one two three fifth START\n"
+ "START nothing should be selected here START\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}